Do I need to update my M1?

It's recommended to update the Xpert Eye solution as soon as a notification appears in the top left-hand corner. The updates usually contain the enhancements or bug fixes which are aimed to improving the performance and security of the Xpert Eye solution. They are mandatory to ensure the compatibility between the Glass Wearer dedicated device and the Remote Observer device.

Did you find it helpful? Yes No

Send feedback
Sorry we couldn't be helpful. Help us improve this article with your feedback.