Which version of Chrome should I install to use XpertEye?

In general, it is recommended to use the latest version of Chrome.

Minimum Chrome Version Required for XpertEye 4.0.0: Chrome 64

Did you find it helpful? Yes No

Send feedback
Sorry we couldn't be helpful. Help us improve this article with your feedback.